Insights Dashboards may fail to load

Resolved

This incident has been resolved.
Posted Oct 04, 2025 - 00:36 UTC

Update

Insights functionality has been restored.
Posted Oct 04, 2025 - 00:36 UTC

Update

We are continuing to investigate this issue.
Posted Oct 03, 2025 - 21:11 UTC

Investigating

Insights Dashboards may fail to load. We are currently investigating the issue.
Posted Oct 03, 2025 - 18:04 UTC
This incident affected: Insights.