Business Apps degraded

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 17:59 UTC

Update

The failure was found to only effect internal tests, no user impact is expected to have occurred.
Posted Jul 08, 2025 - 17:58 UTC

Update

We are continuing to investigate the issue.
Posted Jul 08, 2025 - 17:29 UTC

Investigating

Business apps may fail to load in Automation Cloud Public Sector. We are currently investigating.
Posted Jul 08, 2025 - 16:45 UTC
This incident affected: Apps.