Insights service not loading for some users
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 19:51 UTC
Update
Insights issue has been resolved.
Posted Jun 04, 2024 - 19:50 UTC
Investigating
We are currently investigating the issue
Posted Jun 04, 2024 - 18:36 UTC
This incident affected: Insights.